League client update - Read me if you've patched the alpha since 4pm PDT November 2nd

Hello brave PBE League client update alpha players! Yesterday at approximately 4pm PDT, November 2nd, we applied an update to the alpha that involved some hefty architectural changes to the way we're doing patching, installation, and organizing files on your computer for League. Unfortunately, that update came with bugs. If you patched between then and now (5am November 3rd) your installation is likely to be in a broken state. Symptoms may include persistent crashing, failure to receive new updates, inability to install, and errors when patching. If you're having issues or patched during this time, I'd recommend completely deleting your PBE installation folder, then [reinstalling the PBE](https://support.riotgames.com/hc/en-us/articles/204894140-Installing-the-PBE-Client) and then upgrading to the client update from the legacy launcher (just launch as usual and accept the UPGRADE NOW when it appears). If you'd like to avoid completely re-installing, you can also try the following: 1. Run "Uninstall League client alpha PBE" found in your PBE install folder. 2. ALSO delete the following folder: ...\PBE\RADS\solutions\league_client_sln Let me know if you're still having patching or installation issues after trying the above in the comments, or need any clarification on the above steps - I'll be lurking in this thread for the next couple days. Thanks all! Edit: Removed direct Alpha installer links - it's now safer and recommended to upgrade your client through the legacy launcher.
Share
Report as:
Offensive Spam Harassment Incorrect Board
Cancel