Cannot connect to game

I have played one game with trundle and it disconnected me, now i am unable to connect to any games, the client works fine and my internet works fine, i'm supposed to be in a game right now but it tells me that i am unable to connect to server. Help! Edit: I restarted my computer, restarted lol, I am going to disable firewall temporarily to see if i can connect. Edit: i stopped my firewall, doesn't help. Pinging pbe server on cmd works getting around 130ms. (ping -t) I was in a game and in the endgame screen someone threatened to report me for 'afk' {{sticker:slayer-pantheon-popcorn}} Apparently (i have tried to connect to a couple games) some people are just destined to not connect, i say this because someone that I am duo'ing with has the same problem but the third has never had it... Btw if you have the same problem upvote, we may get more visibility. Edit: Rempler: > [{quoted}](name=Rempler,realm=PBE,application-id=A4D2003433C8FCD715185A7264A9CC6FDFAD7FEF,discussion-id=dbIB2mur,comment-id=000e00000000,timestamp=2018-07-20T12:51:23.777+0000) > > well i could reconnect after i connected to vpn in us, so there might be some issues with some countries this raises an interesting point, maybe its just the IP addresses or something, however I doubt that it has to do with physical location because my third group member is in Belgium and has no problems. Edit: So Rempler informed me I was using the wrong IP adress when pinging, so i will try to do the following one: Every time my request times out, so I am guessing that it is the right one, feel free to try it yourself, just go to cmd and put in this command: (ping -t). Then obviously it would be nice if you commented about the results including if you have the problem or not. Edit: I asked my third party member (for whom the servers worked) to ping the address ( and it worked for him, Though JeuxJeux20 informed me that everyone has a different game IP address allocated to them. so perhaps it was just luck? Edit: They have finally acknowledged and are investigating the bug. Took em 6 hours to realize that there is a problem, probably not their fastest bugfix, either way, its getting fixed {{sticker:sg-kiko}} Edit: The battle has been won! They have patched the issue, as a result I doubt any1 will see this, but I can play now make sure to comment if you still cannot! {{sticker:sg-jinx}}
Report as:
Offensive Spam Harassment Incorrect Board