Play button is greyed out and unclickable. "You may be offline" HELP! ! !

Hey, So my internet is working fine, everything is as it was when i managed to play lastly about 12 hours ago. After logging in i noticed the "Play" button is all Greyed out. When hovering on the Play button i can see the message "You are unable to play because you may be offline." Now this is just nonsense. I can play any online game i have in my library all beside League (on PBE). Now connecting to the main server (Euwest) everything works fine exepct for now... now i just get the "high traffic message" but before that everything was fine. Now, i cannot for the life of me find any information online regarding such problem. Does anyone have any solution? Things i have tried in the past couple of hours. 1. did complete client repair. 2. did complete reinstall 3. restarted my router. (also tried on another network in another place as im using a laptop) did not work on both networks. Point number 3 leads me to believe this is a server issue. But if thats true how come i cannot find any new posts on it. ARURF is up and im sure people are playing right now. Also, if any of you watching also experience this issue please reply to this thread. I want to see if im the only one facing this. Best regards, Acthlion
Report as:
Offensive Spam Harassment Incorrect Board